- Update to r53061
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index 51d7fe5..10df37c 100644 (file)
@@ -1,4 +1,6 @@
 
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
 add_definitions(
     -DHAVE_CONFIG_H
     -DWIN32
@@ -10,8 +12,6 @@ add_definitions(
     -D_WINSOCKAPI_
     -DLIBXML_STATIC)
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
-
 add_library(libxslt SHARED
     attributes.c
     attrvt.c
@@ -34,9 +34,13 @@ add_library(libxslt SHARED
     xsltutils.c)
 
 set_entrypoint(libxslt 0)
-
 target_link_libraries(libxslt libxml2)
-
 add_importlibs(libxslt msvcrt ws2_32 kernel32)
 
-add_dependencies(libxslt psdk buildno_header)
+if(MSVC)
+    add_importlibs(libxslt ntdll)
+endif()
+
+add_dependencies(libxslt psdk)
+add_pch(libxslt libxslt.h)
+add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)