Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index 26111a6..3914bc1 100644 (file)
@@ -1,4 +1,7 @@
 
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}
+                    ${REACTOS_SOURCE_DIR}/include/reactos/libs/libxslt)
+
 add_definitions(
     -DHAVE_CONFIG_H
     -DWIN32
@@ -8,8 +11,7 @@ add_definitions(
     -DHAVE_WIN32_THREADS
     -D_REENTRANT
     -D_WINSOCKAPI_
-    -DLIBXML_STATIC
-    -D_DLL -D__USE_CRTIMP)
+    -DLIBXML_STATIC)
 
 add_library(libxslt SHARED
     attributes.c
@@ -32,15 +34,19 @@ add_library(libxslt SHARED
     xsltlocale.c
     xsltutils.c)
 
-set_entrypoint(libxslt 0)
-
+set_module_type(libxslt win32dll)
 target_link_libraries(libxslt libxml2)
-
 add_importlibs(libxslt msvcrt ws2_32 kernel32)
+
 if(MSVC)
-add_importlibs(libxslt ntdll)
+    add_importlibs(libxslt ntdll)
 endif()
 
-add_dependencies(libxslt psdk buildno_header)
+add_dependencies(libxslt psdk)
+add_pch(libxslt libxslt.h)
+add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)
 
-add_cab_target(libxslt 1)
+if(NOT MSVC)
+    add_target_compile_flags(libxslt "-Wno-pointer-sign -Wno-unused-but-set-variable -Wno-unused-function")
+    allow_warnings(libxslt)
+endif()