[CMAKE] Remove obsolete 'CMAKE_CXX_COMPILER_VERSION' checks (#2981)
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index 988a7ca..d5e2d3b 100644 (file)
@@ -1,6 +1,10 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/libs/libxslt
-                    ${REACTOS_SOURCE_DIR}/lib/3rdparty/libwin-iconv)
+if(NOT MSVC)
+    add_compile_flags("-Wno-misleading-indentation")
+endif()
+
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/libxslt
+                    ${REACTOS_SOURCE_DIR}/sdk/lib/3rdparty/libwin-iconv)
 
 add_definitions(
     -DHAVE_CONFIG_H
@@ -10,7 +14,6 @@ add_definitions(
     -DHAVE_STAT
     -DHAVE_WIN32_THREADS
     -D_REENTRANT
-    -D_WINSOCKAPI_
     -DLIBXML_STATIC)
 
 list(APPEND SOURCE
@@ -35,18 +38,18 @@ list(APPEND SOURCE
     xsltutils.c
     precomp.h)
 
-add_library(libxslt SHARED ${SOURCE})
+add_library(libxslt MODULE ${SOURCE})
 set_module_type(libxslt win32dll)
 target_link_libraries(libxslt libxml2 iconv-static zlib)
 add_importlibs(libxslt msvcrt ws2_32 kernel32)
+
 if(MSVC)
     add_importlibs(libxslt ntdll)
 endif()
 
-add_dependencies(libxslt psdk)
 add_pch(libxslt precomp.h SOURCE)
 add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)
 
-if(NOT MSVC)
-    add_target_compile_flags(libxslt "-Wno-pointer-sign -Wno-unused-but-set-variable -Wno-unused-function")
+if(USE_CLANG_CL OR (NOT MSVC))
+    target_compile_options(libxslt PRIVATE -Wno-pointer-sign -Wno-unused-function)
 endif()