[CMAKE] Remove obsolete 'CMAKE_CXX_COMPILER_VERSION' checks (#2981)
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index e708913..d5e2d3b 100644 (file)
@@ -1,4 +1,8 @@
 
+if(NOT MSVC)
+    add_compile_flags("-Wno-misleading-indentation")
+endif()
+
 include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/libxslt
                     ${REACTOS_SOURCE_DIR}/sdk/lib/3rdparty/libwin-iconv)
 
@@ -34,7 +38,7 @@ list(APPEND SOURCE
     xsltutils.c
     precomp.h)
 
-add_library(libxslt SHARED ${SOURCE})
+add_library(libxslt MODULE ${SOURCE})
 set_module_type(libxslt win32dll)
 target_link_libraries(libxslt libxml2 iconv-static zlib)
 add_importlibs(libxslt msvcrt ws2_32 kernel32)
@@ -47,5 +51,5 @@ add_pch(libxslt precomp.h SOURCE)
 add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)
 
 if(USE_CLANG_CL OR (NOT MSVC))
-    add_target_compile_flags(libxslt "-Wno-pointer-sign -Wno-unused-function")
+    target_compile_options(libxslt PRIVATE -Wno-pointer-sign -Wno-unused-function)
 endif()