[LIBXSLT] Better highlight some ROS diffs. CORE-14291
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index 648ca8d..e708913 100644 (file)
@@ -1,6 +1,6 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/libs/libxslt
-                    ${REACTOS_SOURCE_DIR}/lib/3rdparty/libwin-iconv)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/libxslt
+                    ${REACTOS_SOURCE_DIR}/sdk/lib/3rdparty/libwin-iconv)
 
 add_definitions(
     -DHAVE_CONFIG_H
@@ -10,7 +10,6 @@ add_definitions(
     -DHAVE_STAT
     -DHAVE_WIN32_THREADS
     -D_REENTRANT
-    -D_WINSOCKAPI_
     -DLIBXML_STATIC)
 
 list(APPEND SOURCE
@@ -39,17 +38,14 @@ add_library(libxslt SHARED ${SOURCE})
 set_module_type(libxslt win32dll)
 target_link_libraries(libxslt libxml2 iconv-static zlib)
 add_importlibs(libxslt msvcrt ws2_32 kernel32)
+
 if(MSVC)
     add_importlibs(libxslt ntdll)
 endif()
 
-add_dependencies(libxslt psdk)
 add_pch(libxslt precomp.h SOURCE)
 add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)
 
-if(NOT MSVC)
+if(USE_CLANG_CL OR (NOT MSVC))
     add_target_compile_flags(libxslt "-Wno-pointer-sign -Wno-unused-function")
-    if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
-        add_target_compile_flags(libxslt "-Wno-unused-but-set-variable")
-    endif()
 endif()