[CALC] Fix input bug when display is in error. (#5988)
[reactos.git] / dll / cpl / input / CMakeLists.txt
index 6a262f5..77363d5 100644 (file)
@@ -3,27 +3,28 @@ spec2def(input.dll input.spec)
 
 list(APPEND SOURCE
     input.c
-    settings.c
-    advsettings.c
-    keysettings.c
-    add.c
-    changekeyseq.c
-    input.h)
+    input.h
+    input_list.c
+    input_list.h
+    layout_list.c
+    layout_list.h
+    locale_list.c
+    locale_list.h
+    settings_page.c
+    advanced_settings_page.c
+    add_dialog.c
+    edit_dialog.c
+    key_settings_dialog.c
+    key_sequence_dialog.c)
 
-add_library(input SHARED
+add_rc_deps(input.rc ${CMAKE_CURRENT_SOURCE_DIR}/resources/keyboard-shortcuts.ico)
+
+add_library(input MODULE
     ${SOURCE}
     input.rc
     ${CMAKE_CURRENT_BINARY_DIR}/input.def)
 
 set_module_type(input win32dll UNICODE)
-
-add_importlibs(input
-    msvcrt
-    advapi32
-    user32
-    comctl32
-    gdi32
-    kernel32)
-
+add_importlibs(input advapi32 user32 comctl32 gdi32 msvcrt kernel32 setupapi)
 add_pch(input input.h SOURCE)
 add_cd_file(TARGET input DESTINATION reactos/system32 FOR all)