[CMAKE]
[reactos.git] / dll / cpl / input / CMakeLists.txt
index 6bbfa47..f6da971 100644 (file)
@@ -1,7 +1,8 @@
 
 set_unicode()
+set_rc_compiler()
 
-spec2def(input ${CMAKE_CURRENT_SOURCE_DIR}/input.spec ${CMAKE_CURRENT_BINARY_DIR}/input.def)
+spec2def(input.dll input.spec)
 
 add_library(input SHARED
     input.c
@@ -9,12 +10,11 @@ add_library(input SHARED
     keysettings.c
     add.c
     changekeyseq.c
-    input.rc)
+    input.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/input.def)
 
 set_module_type(input win32dll)
 
-target_link_libraries(input ${CMAKE_CURRENT_BINARY_DIR}/input.def)
-
 add_importlibs(input
     msvcrt
     advapi32
@@ -23,5 +23,4 @@ add_importlibs(input
     gdi32
     kernel32)
 
-add_dependencies(input input_def)
-add_livecd_target(input reactos/system32)
+add_cd_file(TARGET input DESTINATION reactos/system32 FOR all)