[WINHTTP] Sync with Wine Staging 3.9. CORE-14656
[reactos.git] / dll / cpl / intl / CMakeLists.txt
index a675d50..d18db6f 100644 (file)
@@ -1,7 +1,7 @@
 
 spec2def(intl.cpl intl.spec)
 
-add_library(intl SHARED
+list(APPEND SOURCE
     currency.c
     date.c
     generalp.c
@@ -14,20 +14,16 @@ add_library(intl SHARED
     languages.c
     advanced.c
     sort.c
+    intl.h)
+
+add_rc_deps(intl.rc ${CMAKE_CURRENT_SOURCE_DIR}/resources/applet.ico)
+
+add_library(intl SHARED
+    ${SOURCE}
     intl.rc
     ${CMAKE_CURRENT_BINARY_DIR}/intl.def)
 
 set_module_type(intl cpl UNICODE)
-
-add_importlibs(intl
-    msvcrt
-    user32
-    comctl32
-    advapi32
-    setupapi
-    shell32
-    kernel32
-    ntdll)
-
-add_pch(intl intl.h)
+add_importlibs(intl user32 comctl32 advapi32 setupapi shell32 msvcrt kernel32 ntdll)
+add_pch(intl intl.h SOURCE)
 add_cd_file(TARGET intl DESTINATION reactos/system32 FOR all)