[ACPPAGE] Make use of the PCH.
[reactos.git] / dll / cpl / powercfg / CMakeLists.txt
index 93fb40a..fadd507 100644 (file)
@@ -9,22 +9,15 @@ list(APPEND SOURCE
     hibernate.c
     powercfg.h)
 
+file(GLOB powercfg_rc_deps resources/*.*)
+add_rc_deps(powercfg.rc ${powercfg_rc_deps})
+
 add_library(powercfg SHARED
     ${SOURCE}
     powercfg.rc
     ${CMAKE_CURRENT_BINARY_DIR}/powercfg.def)
 
 set_module_type(powercfg cpl UNICODE)
-
-add_importlibs(powercfg
-    msvcrt
-    user32
-    powrprof
-    comctl32
-    shell32
-    advapi32
-    kernel32
-    ntdll)
-
+add_importlibs(powercfg shlwapi user32 powrprof comctl32 shell32 advapi32 msvcrt kernel32 ntdll)
 add_pch(powercfg powercfg.h SOURCE)
 add_cd_file(TARGET powercfg DESTINATION reactos/system32 FOR all)