Sync with trunk r62754.
[reactos.git] / dll / cpl / telephon / CMakeLists.txt
index bc7c9e4..cb53705 100644 (file)
@@ -1,13 +1,8 @@
 
-set_unicode()
-
-spec2def(telephon ${CMAKE_CURRENT_SOURCE_DIR}/telephon.spec ${CMAKE_CURRENT_BINARY_DIR}/telephon.def)
-
-add_library(telephon SHARED telephon.c telephon.rc)
-
-set_module_type(telephon cpl)
-
-target_link_libraries(telephon ${CMAKE_CURRENT_BINARY_DIR}/telephon.def uuid)
+spec2def(telephon.cpl telephon.spec)
+add_library(telephon SHARED telephon.c telephon.rc ${CMAKE_CURRENT_BINARY_DIR}/telephon.def)
+set_module_type(telephon cpl UNICODE)
+target_link_libraries(telephon uuid)
 
 add_importlibs(telephon
     advapi32
@@ -15,7 +10,7 @@ add_importlibs(telephon
     comctl32
     ole32
     shell32
+    msvcrt
     kernel32)
 
-add_dependencies(telephon telephon_def)
-add_livecd_target(telephon reactos/system32)
+add_cd_file(TARGET telephon DESTINATION reactos/system32 FOR all)