[BROWSEUI]
[reactos.git] / dll / cpl / timedate / CMakeLists.txt
index 8c656c5..5d87b27 100644 (file)
@@ -1,9 +1,7 @@
 
-set_unicode()
-
 spec2def(timedate.cpl timedate.spec)
 
-add_library(timedate SHARED
+list(APPEND SOURCE
     clock.c
     dateandtime.c
     internettime.c
@@ -11,10 +9,14 @@ add_library(timedate SHARED
     ntpclient.c
     timedate.c
     timezone.c
+    timedate.h)
+
+add_library(timedate SHARED
+    ${SOURCE}
     timedate.rc
     ${CMAKE_CURRENT_BINARY_DIR}/timedate.def)
 
-set_module_type(timedate cpl)
+set_module_type(timedate cpl UNICODE)
 
 add_importlibs(timedate
     advapi32
@@ -26,4 +28,5 @@ add_importlibs(timedate
     msvcrt
     kernel32)
 
-add_cab_target(timedate 1)
+add_pch(timedate timedate.h SOURCE)
+add_cd_file(TARGET timedate DESTINATION reactos/system32 FOR all)