[BROWSEUI]
[reactos.git] / dll / cpl / timedate / CMakeLists.txt
index e82bcce..5d87b27 100644 (file)
@@ -1,9 +1,7 @@
 
-set_unicode()
+spec2def(timedate.cpl timedate.spec)
 
-spec2def(timedate ${CMAKE_CURRENT_SOURCE_DIR}/timedate.spec ${CMAKE_CURRENT_BINARY_DIR}/timedate.def)
-
-add_library(timedate SHARED
+list(APPEND SOURCE
     clock.c
     dateandtime.c
     internettime.c
@@ -11,11 +9,14 @@ add_library(timedate SHARED
     ntpclient.c
     timedate.c
     timezone.c
-    timedate.rc)
+    timedate.h)
 
-set_module_type(timedate cpl)
+add_library(timedate SHARED
+    ${SOURCE}
+    timedate.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/timedate.def)
 
-target_link_libraries(timedate ${CMAKE_CURRENT_BINARY_DIR}/timedate.def)
+set_module_type(timedate cpl UNICODE)
 
 add_importlibs(timedate
     advapi32
@@ -27,5 +28,5 @@ add_importlibs(timedate
     msvcrt
     kernel32)
 
-add_dependencies(timedate timedate_def)
-add_livecd_target(timedate reactos/system32)
+add_pch(timedate timedate.h SOURCE)
+add_cd_file(TARGET timedate DESTINATION reactos/system32 FOR all)