[CMAKE]
[reactos.git] / dll / directx / dplay / CMakeLists.txt
index 7f7d1cf..ca8c48d 100644 (file)
@@ -3,14 +3,16 @@ set_unicode()
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(dplay ${CMAKE_CURRENT_SOURCE_DIR}/dplay.spec ${CMAKE_CURRENT_BINARY_DIR}/dplay.def)
+spec2def(dplay.dll dplay.spec)
 
-add_library(dplay SHARED dplay_main.c version.rc)
+add_library(dplay SHARED
+    dplay_main.c
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/dplay.def)
 
 set_entrypoint(dplay 0)
 
 target_link_libraries(dplay
-    ${CMAKE_CURRENT_BINARY_DIR}/dplay.def
     uuid
     wine)
 
@@ -20,6 +22,10 @@ add_importlibs(dplay
     ole32
     winmm
     dinput
+    dplayx
     ntdll)
 
-add_dependencies(dplay dplay_def psdk buildno_header)
+add_dependencies(dplay psdk)
+
+add_cd_file(TARGET dplay DESTINATION reactos/system32)
+add_importlib_target(dplay.spec libdplayx)