[CMAKE]
[reactos.git] / dll / directx / dplayx / CMakeLists.txt
index 6460c03..77c8074 100644 (file)
@@ -1,3 +1,4 @@
+
 set_rc_compiler()
 
 spec2def(dplayx.dll dplayx.spec)
@@ -14,7 +15,7 @@ list(APPEND SOURCE
     name_server.c
     regsvr.c
     version.rc
-    dplayx.def)
+    ${CMAKE_CURRENT_BINARY_DIR}/dplayx.def)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
@@ -22,7 +23,6 @@ add_library(dplayx SHARED ${SOURCE})
 set_module_type(dplayx win32dll)
 
 target_link_libraries(dplayx
-    ${CMAKE_CURRENT_BINARY_DIR}/dplayx.def
     wine
     uuid
     dxguid)
@@ -35,4 +35,6 @@ add_importlibs(dplayx
     msvcrt
     kernel32
     ntdll)
-    
\ No newline at end of file
+
+add_cd_file(TARGET dplayx DESTINATION reactos/system32 FOR all)
+add_importlib_target(dplayx.spec)