Sync with trunk r58740.
[reactos.git] / dll / directx / dplayx / CMakeLists.txt
index fbf7cea..dfb38fd 100644 (file)
@@ -1,4 +1,10 @@
 
+add_definitions(
+    -DCOM_NO_WINDOWS_H
+    -D__WINESRC__)
+
+include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+
 spec2def(dplayx.dll dplayx.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -11,23 +17,10 @@ list(APPEND SOURCE
     dplobby.c
     lobbysp.c
     name_server.c
-    regsvr.c
-    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/dplayx.def)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
-add_library(dplayx SHARED ${SOURCE})
+add_library(dplayx SHARED ${SOURCE} version.rc)
 set_module_type(dplayx win32dll)
-target_link_libraries(dplayx wine uuid dxguid)
-
-add_importlibs(dplayx
-    advapi32
-    ole32
-    user32
-    winmm
-    msvcrt
-    kernel32
-    ntdll)
-
+target_link_libraries(dplayx dxguid uuid wine)
+add_importlibs(dplayx winmm ole32 user32 advapi32 msvcrt kernel32 ntdll)
 add_cd_file(TARGET dplayx DESTINATION reactos/system32 FOR all)