[AMSTREAM] We don't need to define WIDL_C_INLINE_WRAPPERS here anymore.
[reactos.git] / dll / directx / wine / amstream / CMakeLists.txt
index 7553c82..b6e6b86 100644 (file)
@@ -1,9 +1,7 @@
 
-add_definitions(
-    -D__WINESRC__
-    -DWIDL_C_INLINE_WRAPPERS)
+add_definitions(-D__WINESRC__)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(amstream.dll amstream.spec)
 
 list(APPEND SOURCE
@@ -12,10 +10,15 @@ list(APPEND SOURCE
     main.c
     mediastream.c
     mediastreamfilter.c
+    amstream_private.h)
+
+add_library(amstream SHARED
+    ${SOURCE}
+    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/amstream.def)
 
-add_library(amstream SHARED ${SOURCE} version.rc)
 set_module_type(amstream win32dll)
 target_link_libraries(amstream strmbase strmiids uuid wine)
-add_importlibs(amstream ole32 msvcrt kernel32 ntdll)
+add_importlibs(amstream ole32 ddraw user32 msvcrt kernel32 ntdll)
+add_pch(amstream amstream_private.h SOURCE)
 add_cd_file(TARGET amstream DESTINATION reactos/system32 FOR all)