[CMAKE]
[reactos.git] / dll / directx / wine / d3d8 / CMakeLists.txt
index aa3bcd9..0b44eeb 100644 (file)
@@ -1,33 +1,37 @@
-
+set_rc_compiler()
 set_unicode()
 
 add_definitions(-D__WINESRC__)
 add_definitions(-DUSE_WIN32_OPENGL)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(d3d8 ${CMAKE_CURRENT_SOURCE_DIR}/d3d8.spec ${CMAKE_CURRENT_BINARY_DIR}/d3d8.def)
+if(MSVC)
+    add_definitions(-FImsvchelper.h)
+endif()
+
+spec2def(d3d8.dll d3d8.spec)
 
-add_library(d3d8 SHARED
+list(APPEND SOURCE
+    buffer.c
     cubetexture.c
     d3d8_main.c
     device.c
     directx.c
-    indexbuffer.c
-    pixelshader.c
+    shader.c
     surface.c
     swapchain.c
     texture.c
-    vertexbuffer.c
     vertexdeclaration.c
-    vertexshader.c
     volume.c
     volumetexture.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/d3d8.def)
+
+add_library(d3d8 SHARED ${SOURCE})
 
 set_module_type(d3d8 win32dll)
 
 target_link_libraries(d3d8
-    ${CMAKE_CURRENT_BINARY_DIR}/d3d8.def
     uuid
     wine)
 
@@ -35,7 +39,10 @@ add_importlibs(d3d8
     user32
     gdi32
     advapi32
-    wined3d)
+    wined3d
+    msvcrt
+    kernel32
+    ntdll)
 
-add_dependencies(d3d8 d3d8_def wineheaders)
-add_livecd_target(d3d8 reactos/system32)
+add_dependencies(d3d8 wineheaders)
+add_cab_target(d3d8 1)