- Update to r53061
[reactos.git] / dll / directx / wine / d3d8 / CMakeLists.txt
index bbb58aa..4958236 100644 (file)
@@ -1,10 +1,14 @@
-set_rc_compiler()
+
 set_unicode()
 
-add_definitions(-D__WINESRC__)
-add_definitions(-DUSE_WIN32_OPENGL)
+add_definitions(
+    -D__WINESRC__
+    -DUSE_WIN32_OPENGL)
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
+set_rc_compiler()
+
 spec2def(d3d8.dll d3d8.spec)
 
 list(APPEND SOURCE
@@ -21,15 +25,13 @@ list(APPEND SOURCE
     volume.c
     volumetexture.c
     version.rc
-    d3d8.def)
+    ${CMAKE_CURRENT_BINARY_DIR}/d3d8.def)
 
 add_library(d3d8 SHARED ${SOURCE})
 
 set_module_type(d3d8 win32dll)
 
-target_link_libraries(d3d8
-    uuid
-    wine)
+target_link_libraries(d3d8 uuid wine)
 
 add_importlibs(d3d8
     user32
@@ -41,4 +43,5 @@ add_importlibs(d3d8
     ntdll)
 
 add_dependencies(d3d8 wineheaders)
-add_cab_target(d3d8 1)
+add_pch(d3d8 d3d8_private.h)
+add_cd_file(TARGET d3d8 DESTINATION reactos/system32 FOR all)