[D3D8][D3D9][DDRAW][WINED3D] Use modules instead of shared libraries
[reactos.git] / dll / directx / wine / d3d8 / CMakeLists.txt
index 338fded..d3d49e2 100644 (file)
@@ -3,7 +3,7 @@ add_definitions(
     -D__WINESRC__
     -DUSE_WIN32_OPENGL)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(d3d8.dll d3d8.spec)
 
 list(APPEND SOURCE
@@ -17,16 +17,16 @@ list(APPEND SOURCE
     texture.c
     vertexdeclaration.c
     volume.c
-    d3d8_private.h)
+    precomp.h)
 
-add_library(d3d8 SHARED
+add_library(d3d8 MODULE
     ${SOURCE}
     guid.c
     version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/d3d8.def)
 
-set_module_type(d3d8 win32dll UNICODE HOTPATCHABLE)
+set_module_type(d3d8 win32dll UNICODE)
 target_link_libraries(d3d8 uuid wine)
 add_importlibs(d3d8 d3dwine msvcrt kernel32 ntdll)
-add_pch(d3d8 d3d8_private.h SOURCE)
+add_pch(d3d8 precomp.h SOURCE)
 add_cd_file(TARGET d3d8 DESTINATION reactos/system32 FOR all)