[D3D8][D3D9][DDRAW][WINED3D] Use modules instead of shared libraries
[reactos.git] / dll / directx / wine / d3d9 / CMakeLists.txt
index 9dd8b4a..14dd3e6 100644 (file)
@@ -19,9 +19,9 @@ list(APPEND SOURCE
     texture.c
     vertexdeclaration.c
     volume.c
-    d3d9_private.h)
+    precomp.h)
 
-add_library(d3d9 SHARED
+add_library(d3d9 MODULE
     ${SOURCE}
     guid.c
     version.rc
@@ -31,5 +31,5 @@ add_library(d3d9 SHARED
 set_module_type(d3d9 win32dll UNICODE)
 target_link_libraries(d3d9 wine)
 add_importlibs(d3d9 d3dwine user32 msvcrt kernel32 ntdll)
-add_pch(d3d9 d3d9_private.h SOURCE)
+add_pch(d3d9 precomp.h SOURCE)
 add_cd_file(TARGET d3d9 DESTINATION reactos/system32 FOR all)