[AMSTREAM] We don't need to define WIDL_C_INLINE_WRAPPERS here anymore.
[reactos.git] / dll / directx / wine / d3d9 / CMakeLists.txt
index 330dc93..9dd8b4a 100644 (file)
@@ -3,8 +3,7 @@ add_definitions(
     -D__WINESRC__
     -DUSE_WIN32_OPENGL)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(d3d9.dll d3d9.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -29,8 +28,8 @@ add_library(d3d9 SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/d3d9_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/d3d9.def)
 
-set_module_type(d3d9 win32dll UNICODE HOTPATCHABLE)
+set_module_type(d3d9 win32dll UNICODE)
 target_link_libraries(d3d9 wine)
-add_importlibs(d3d9 wined3d msvcrt kernel32 ntdll)
+add_importlibs(d3d9 d3dwine user32 msvcrt kernel32 ntdll)
 add_pch(d3d9 d3d9_private.h SOURCE)
 add_cd_file(TARGET d3d9 DESTINATION reactos/system32 FOR all)