[AMSTREAM] We don't need to define WIDL_C_INLINE_WRAPPERS here anymore.
[reactos.git] / dll / directx / wine / d3dx9_36 / CMakeLists.txt
index d366786..1b56e54 100644 (file)
@@ -1,10 +1,10 @@
 
-add_definitions(-D__WINESRC__)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
+add_definitions(-D__WINESRC__ -Dcopysignf=_copysignf -D_D3DX9_VER=36)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(d3dx9_36.dll d3dx9_36.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
+    animation.c
     core.c
     d3dx9_36_main.c
     effect.c
@@ -12,6 +12,7 @@ list(APPEND SOURCE
     line.c
     math.c
     mesh.c
+    preshader.c
     render.c
     shader.c
     skin.c
@@ -33,11 +34,6 @@ add_library(d3dx9_36 SHARED
 set_module_type(d3dx9_36 win32dll)
 add_dependencies(d3dx9_36 d3d_idl_headers)
 target_link_libraries(d3dx9_36 dxguid wine)
-
-if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
-    target_link_libraries(d3dx9_36 mingwex)
-endif()
-
-add_importlibs(d3dx9_36 d3dcompiler_43 d3dxof user32 ole32 gdi32 msvcrt kernel32 ntdll)
+add_importlibs(d3dx9_36 d3dcompiler_43 d3dxof d3dwine user32 ole32 gdi32 msvcrt kernel32 ntdll)
 add_pch(d3dx9_36 d3dx9_36_private.h SOURCE)
 add_cd_file(TARGET d3dx9_36 DESTINATION reactos/system32 FOR all)