* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / directx / wine / d3dxof / CMakeLists.txt
index 0cf261b..3219363 100644 (file)
@@ -7,12 +7,17 @@ spec2def(d3dxof.dll d3dxof.spec ADD_IMPORTLIB)
 list(APPEND SOURCE
     d3dxof.c
     main.c
-    mszip.c
     parsing.c
+    d3dxof_private.h)
+
+add_library(d3dxof SHARED
+    ${SOURCE}
+    mszip.c
+    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/d3dxof.def)
 
-add_library(d3dxof SHARED ${SOURCE} version.rc)
 set_module_type(d3dxof win32dll)
 target_link_libraries(d3dxof dxguid uuid wine)
 add_importlibs(d3dxof msvcrt kernel32 ntdll)
+add_pch(d3dxof d3dxof_private.h SOURCE)
 add_cd_file(TARGET d3dxof DESTINATION reactos/system32 FOR all)