* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / directx / wine / dmusic / CMakeLists.txt
index 1ed4864..6bb39f0 100644 (file)
@@ -12,11 +12,15 @@ list(APPEND SOURCE
     download.c
     instrument.c
     port.c
+    dmusic_private.h)
+
+add_library(dmusic SHARED
+    ${SOURCE}
+    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/dmusic.def)
 
-add_library(dmusic SHARED ${SOURCE} version.rc)
 set_module_type(dmusic win32dll)
 target_link_libraries(dmusic dxguid uuid wine)
 add_importlibs(dmusic ole32 advapi32 winmm msvcrt kernel32 ntdll)
-add_pch(dmusic dmusic_private.h)
+add_pch(dmusic dmusic_private.h SOURCE)
 add_cd_file(TARGET dmusic DESTINATION reactos/system32 FOR all)