[AMSTREAM] We don't need to define WIDL_C_INLINE_WRAPPERS here anymore.
[reactos.git] / dll / directx / wine / dplayx / CMakeLists.txt
index dfb38fd..bf9a7ed 100644 (file)
@@ -3,8 +3,7 @@ add_definitions(
     -DCOM_NO_WINDOWS_H
     -D__WINESRC__)
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine)
 spec2def(dplayx.dll dplayx.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -17,10 +16,15 @@ list(APPEND SOURCE
     dplobby.c
     lobbysp.c
     name_server.c
+    dplayx_global.h)
+
+add_library(dplayx SHARED
+    ${SOURCE}
+    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/dplayx.def)
 
-add_library(dplayx SHARED ${SOURCE} version.rc)
 set_module_type(dplayx win32dll)
 target_link_libraries(dplayx dxguid uuid wine)
 add_importlibs(dplayx winmm ole32 user32 advapi32 msvcrt kernel32 ntdll)
+add_pch(dplayx dplayx_global.h SOURCE)
 add_cd_file(TARGET dplayx DESTINATION reactos/system32 FOR all)