Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / dll / nls / idndl / CMakeLists.txt
diff --git a/dll/nls/idndl/CMakeLists.txt b/dll/nls/idndl/CMakeLists.txt
new file mode 100644 (file)
index 0000000..590ceec
--- /dev/null
@@ -0,0 +1,19 @@
+
+remove_definitions(-DWINVER=0x502)
+add_definitions(-DWINVER=0x600)
+
+spec2def(idndl.dll idndl.spec)
+
+add_library(idndl SHARED
+    idndl.cpp
+    ${CMAKE_CURRENT_BINARY_DIR}/idndl.def)
+
+set_entrypoint(idndl 0)
+
+if(NOT MSVC)
+    add_target_compile_flags(idndl "-fno-exceptions -fno-rtti")
+endif()
+
+add_importlibs(idndl kernel32)
+add_dependencies(idndl psdk)
+add_cd_file(TARGET idndl DESTINATION reactos FOR all)