[CMAKE]
[reactos.git] / dll / ntdll / CMakeLists.txt
index 3ec7ea1..77ee4c6 100644 (file)
@@ -1,12 +1,14 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES>")
+spec2def(ntdll.dll def/ntdll.spec)
 
-add_definitions(-D__NTDLL__)
-add_definitions(-D_NTOSKRNL_)
-add_definitions(-DCRTDLL)
+add_definitions(
+    -D__NTDLL__
+    -D_NTOSKRNL_
+    -DCRTDLL)
 
-include_directories(BEFORE include)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+include_directories(
+    BEFORE include
+    ${REACTOS_SOURCE_DIR}/include/reactos/subsys)
 
 list(APPEND SOURCE
     csr/api.c
@@ -18,8 +20,9 @@ list(APPEND SOURCE
     ldr/actctx.c
     rtl/libsupp.c
     rtl/version.c
-    def/ntdll.rc)
-
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+    
 if(ARCH MATCHES i386)
 list(APPEND SOURCE dispatch/i386/dispatch.S)
 elseif(ARCH MATCHES amd64)
@@ -31,16 +34,25 @@ list(APPEND SOURCE dispatch/dispatch.c)
 endif(ARCH MATCHES i386)
 
 add_library(ntdll SHARED
-    ${SOURCE}
-    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_ntdll.h.gch)
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_ntdll.h.gch
+    ${SOURCE})
+
+set_entrypoint(ntdll 0)
 
-set_target_properties(ntdll PROPERTIES LINK_FLAGS "-Wl,-entry,0")
+if(MSVC)
+target_link_libraries(ntdll rtl)
+else()
+target_link_libraries(ntdll -Wl,--whole-archive rtl -Wl,--no-whole-archive)
+endif()
 
-target_link_libraries(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/def/ntdll.def
-                      -Wl,--whole-archive rtl -Wl,--no-whole-archive
+target_link_libraries(ntdll
                       ntdllsys
                       libcntpr
-                      pseh)
+                      ${PSEH_LIB})
                       
 add_pch(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h ${SOURCE})
-add_dependencies(ntdll ntstatus version)
+add_dependencies(ntdll ntstatus asm)
+
+add_minicd_target(ntdll reactos/system32 ntdll.dll)
+add_cab_target(ntdll 1)
+add_importlib_target(def/ntdll.spec)