[CMAKE]
[reactos.git] / dll / ntdll / CMakeLists.txt
index 9de0d41..77ee4c6 100644 (file)
@@ -21,7 +21,7 @@ list(APPEND SOURCE
     rtl/libsupp.c
     rtl/version.c
     def/ntdll.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/def/ntdll.def)
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
     
 if(ARCH MATCHES i386)
 list(APPEND SOURCE dispatch/i386/dispatch.S)
@@ -48,11 +48,11 @@ endif()
 target_link_libraries(ntdll
                       ntdllsys
                       libcntpr
-                      pseh)
+                      ${PSEH_LIB})
                       
 add_pch(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h ${SOURCE})
-add_dependencies(ntdll ntstatus)
+add_dependencies(ntdll ntstatus asm)
 
 add_minicd_target(ntdll reactos/system32 ntdll.dll)
 add_cab_target(ntdll 1)
-add_importlib_target(ntdll)
\ No newline at end of file
+add_importlib_target(def/ntdll.spec)