[CMAKE]
[reactos.git] / dll / ntdll / CMakeLists.txt
index e2b7908..77ee4c6 100644 (file)
@@ -1,21 +1,58 @@
 
-SET(CMAKE_C_CREATE_SHARED_LIBRARY
-  "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -Wl,--enable-stdcall-fixup -Wl,--kill-at -o <TARGET> <OBJECTS> ${CMAKE_CURRENT_SOURCE_DIR}/def/ntdll.def <LINK_LIBRARIES>")
+spec2def(ntdll.dll def/ntdll.spec)
 
-add_definitions(-D__NTDLL__)
-add_definitions(-D_NTOSKRNL_)
-add_definitions(-DCRTDLL)
+add_definitions(
+    -D__NTDLL__
+    -D_NTOSKRNL_
+    -DCRTDLL)
 
-include_directories(BEFORE ./include)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+include_directories(
+    BEFORE include
+    ${REACTOS_SOURCE_DIR}/include/reactos/subsys)
 
-file(GLOB_RECURSE SOURCE *.c)
-list(REMOVE_ITEM SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/ldr/elf.c ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/dispatch.c)
-list(REMOVE_ITEM SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/amd64/stubs.c)
+list(APPEND SOURCE
+    csr/api.c
+    csr/capture.c
+    csr/connect.c
+    dbg/dbgui.c
+    ldr/startup.c
+    ldr/utils.c
+    ldr/actctx.c
+    rtl/libsupp.c
+    rtl/version.c
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+    
+if(ARCH MATCHES i386)
+list(APPEND SOURCE dispatch/i386/dispatch.S)
+elseif(ARCH MATCHES amd64)
+list(APPEND SOURCE dispatch/amd64/stubs.c)
+elseif(ARCH MATCHES arm)
+list(APPEND SOURCE dispatch/arm/stubs_asm.s)
+else()
+list(APPEND SOURCE dispatch/dispatch.c)
+endif(ARCH MATCHES i386)
 
-file(GLOB_RECURSE ARCH_SOURCE "${CMAKE_CURRENT_SOURCE_DIR}/dispatch/${ARCH}/*.c" "${CMAKE_CURRENT_SOURCE_DIR}/dispatch/${ARCH}/*.s")
+add_library(ntdll SHARED
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_ntdll.h.gch
+    ${SOURCE})
 
-add_library(ntdll SHARED ${ARCH_SOURCE} ${SOURCE} ${CMAKE_CURRENT_SOURCE_DIR}/def/ntdll.rc  ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h.gch)
-target_link_libraries(ntdll rtl ntdllsys libcntpr pseh)
+set_entrypoint(ntdll 0)
+
+if(MSVC)
+target_link_libraries(ntdll rtl)
+else()
+target_link_libraries(ntdll -Wl,--whole-archive rtl -Wl,--no-whole-archive)
+endif()
+
+target_link_libraries(ntdll
+                      ntdllsys
+                      libcntpr
+                      ${PSEH_LIB})
+                      
 add_pch(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h ${SOURCE})
-add_dependencies(ntdll ntstatus version)
\ No newline at end of file
+add_dependencies(ntdll ntstatus asm)
+
+add_minicd_target(ntdll reactos/system32 ntdll.dll)
+add_cab_target(ntdll 1)
+add_importlib_target(def/ntdll.spec)