[BASESRV-CONSRV-WINSRV]
[reactos.git] / dll / ntdll / CMakeLists.txt
index 8743951..7ad8547 100644 (file)
@@ -1,19 +1,57 @@
-add_definitions(-D__NTDLL__)
-add_definitions(-D_NTOSKRNL_)
-add_definitions(-DCRTDLL)
 
-SET(CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE 1)
+spec2def(ntdll.dll def/ntdll.spec ADD_IMPORTLIB)
 
-include_directories(BEFORE ./include)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+add_definitions(
+    -D__NTDLL__
+    -D_NTOSKRNL_
+    -DCRTDLL)
 
-file(GLOB_RECURSE SOURCE *.c)
-list(REMOVE_ITEM SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/ldr/elf.c ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/dispatch.c)
-list(REMOVE_ITEM SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/amd64/stubs.c)
+include_directories(
+    BEFORE include
+    ${REACTOS_SOURCE_DIR}/include/reactos/subsys
+    ${REACTOS_SOURCE_DIR}/win32ss/include)
 
-file(GLOB_RECURSE ARCH_SOURCE "${CMAKE_CURRENT_SOURCE_DIR}/dispatch/${ARCH}/*.c" "${CMAKE_CURRENT_SOURCE_DIR}/dispatch/${ARCH}/*.s")
+list(APPEND SOURCE
+    csr/api.c
+    csr/capture.c
+    csr/connect.c
+    dbg/dbgui.c
+    ldr/ldrapi.c
+    ldr/ldrinit.c
+    ldr/ldrpe.c
+    ldr/ldrutils.c
+    rtl/libsupp.c
+    rtl/version.c
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
 
-add_library(ntdll SHARED ${ARCH_SOURCE} ${SOURCE})
+if(ARCH STREQUAL "i386")
+    list(APPEND ASM_SOURCE dispatch/i386/dispatch.S)
+elseif(ARCH STREQUAL "amd64")
+    list(APPEND ASM_SOURCE dispatch/amd64/dispatch.S)
+elseif(ARCH STREQUAL "arm")
+    list(APPEND ASM_SOURCE dispatch/arm/stubs_asm.s)
+else()
+    list(APPEND SOURCE dispatch/dispatch.c)
+endif()
+
+add_asm_files(ntdll_asm ${ASM_SOURCE})
+add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
+
+set_module_type(ntdll win32dll ENTRYPOINT 0)
+
+if(MSVC)
+    add_target_link_flags(ntdll "/RELEASE")
+endif()
+
+target_link_libraries(ntdll
+                      rtl
+                      ntdllsys
+                      libcntpr
+                      ${PSEH_LIB})
+
+add_pch(ntdll include/ntdll.h)
+add_dependencies(ntdll ntstatus asm)
+
+add_cd_file(TARGET ntdll DESTINATION reactos/system32 NO_CAB FOR all)
 
-target_link_libraries(ntdll rtl ntdllsys libcntpr pseh)
-add_dependencies(ntdll ntstatus version)
\ No newline at end of file