[BASESRV-CONSRV-WINSRV]
[reactos.git] / dll / ntdll / CMakeLists.txt
index eaac8df..7ad8547 100644 (file)
@@ -1,4 +1,6 @@
 
+spec2def(ntdll.dll def/ntdll.spec ADD_IMPORTLIB)
+
 add_definitions(
     -D__NTDLL__
     -D_NTOSKRNL_
@@ -6,50 +8,50 @@ add_definitions(
 
 include_directories(
     BEFORE include
-    ${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+    ${REACTOS_SOURCE_DIR}/include/reactos/subsys
+    ${REACTOS_SOURCE_DIR}/win32ss/include)
 
 list(APPEND SOURCE
     csr/api.c
     csr/capture.c
     csr/connect.c
     dbg/dbgui.c
-    ldr/startup.c
-    ldr/utils.c
-    ldr/actctx.c
+    ldr/ldrapi.c
+    ldr/ldrinit.c
+    ldr/ldrpe.c
+    ldr/ldrutils.c
     rtl/libsupp.c
     rtl/version.c
-    def/ntdll.rc)
-
-if(ARCH MATCHES i386)
-list(APPEND SOURCE dispatch/i386/dispatch.S)
-elseif(ARCH MATCHES amd64)
-list(APPEND SOURCE dispatch/amd64/stubs.c)
-elseif(ARCH MATCHES arm)
-list(APPEND SOURCE dispatch/arm/stubs_asm.s)
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+
+if(ARCH STREQUAL "i386")
+    list(APPEND ASM_SOURCE dispatch/i386/dispatch.S)
+elseif(ARCH STREQUAL "amd64")
+    list(APPEND ASM_SOURCE dispatch/amd64/dispatch.S)
+elseif(ARCH STREQUAL "arm")
+    list(APPEND ASM_SOURCE dispatch/arm/stubs_asm.s)
 else()
-list(APPEND SOURCE dispatch/dispatch.c)
-endif(ARCH MATCHES i386)
+    list(APPEND SOURCE dispatch/dispatch.c)
+endif()
 
-add_library(ntdll SHARED
-    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_ntdll.h.gch
-    ${SOURCE})
+add_asm_files(ntdll_asm ${ASM_SOURCE})
+add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
 
-set_entrypoint(ntdll 0)
+set_module_type(ntdll win32dll ENTRYPOINT 0)
 
 if(MSVC)
-target_link_libraries(ntdll rtl)
-else()
-target_link_libraries(ntdll -Wl,--whole-archive rtl -Wl,--no-whole-archive)
+    add_target_link_flags(ntdll "/RELEASE")
 endif()
 
 target_link_libraries(ntdll
-    ${CMAKE_CURRENT_SOURCE_DIR}/def/ntdll.def
-    ntdllsys
-    libcntpr
-    pseh)
-                      
-add_pch(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h ${SOURCE})
-add_dependencies(ntdll ntstatus)
-
-add_minicd_target(ntdll reactos/system32 ntdll.dll)
-add_cab_target(ntdll 1)
+                      rtl
+                      ntdllsys
+                      libcntpr
+                      ${PSEH_LIB})
+
+add_pch(ntdll include/ntdll.h)
+add_dependencies(ntdll ntstatus asm)
+
+add_cd_file(TARGET ntdll DESTINATION reactos/system32 NO_CAB FOR all)
+