[SDK][ACGENRAL] Add the shim IgnoreFreeLibrary
[reactos.git] / dll / ntdll / CMakeLists.txt
index 7ad8547..aefdaf5 100644 (file)
@@ -8,8 +8,7 @@ add_definitions(
 
 include_directories(
     BEFORE include
-    ${REACTOS_SOURCE_DIR}/include/reactos/subsys
-    ${REACTOS_SOURCE_DIR}/win32ss/include)
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/subsys)
 
 list(APPEND SOURCE
     csr/api.c
@@ -21,9 +20,10 @@ list(APPEND SOURCE
     ldr/ldrpe.c
     ldr/ldrutils.c
     rtl/libsupp.c
+    rtl/uilist.c
     rtl/version.c
-    def/ntdll.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+    etw/trace.c
+    include/ntdll.h)
 
 if(ARCH STREQUAL "i386")
     list(APPEND ASM_SOURCE dispatch/i386/dispatch.S)
@@ -36,22 +36,25 @@ else()
 endif()
 
 add_asm_files(ntdll_asm ${ASM_SOURCE})
-add_library(ntdll SHARED ${SOURCE} ${ntdll_asm})
+
+add_library(ntdll SHARED
+    ${SOURCE}
+    ${ntdll_asm}
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
 
 set_module_type(ntdll win32dll ENTRYPOINT 0)
+#############################################
+## HACK FOR MSVC COMPILATION WITH win32dll ##
+set_subsystem(ntdll console)
+################# END  HACK #################
 
 if(MSVC)
     add_target_link_flags(ntdll "/RELEASE")
 endif()
 
-target_link_libraries(ntdll
-                      rtl
-                      ntdllsys
-                      libcntpr
-                      ${PSEH_LIB})
-
-add_pch(ntdll include/ntdll.h)
+target_link_libraries(ntdll rtl ntdllsys libcntpr uuid ${PSEH_LIB})
+add_pch(ntdll include/ntdll.h SOURCE)
 add_dependencies(ntdll ntstatus asm)
-
 add_cd_file(TARGET ntdll DESTINATION reactos/system32 NO_CAB FOR all)
-