[NTDLL][ARM] Export pow
[reactos.git] / dll / ntdll / def / ntdll.spec
index 6abb775..6a60709 100644 (file)
@@ -48,8 +48,8 @@
 48 stdcall -stub EtwCreateTraceInstanceId(ptr ptr)
 49 stdcall EtwEnableTrace(long long long ptr double)
 50 stdcall -stub EtwEnumerateTraceGuids(ptr long ptr)
-51 stdcall -stub EtwFlushTraceA(double str ptr)
-52 stdcall -stub EtwFlushTraceW(double wstr ptr)
+51 stdcall EtwFlushTraceA(double str ptr)
+52 stdcall EtwFlushTraceW(double wstr ptr)
 53 stdcall EtwGetTraceEnableFlags(double)
 54 stdcall EtwGetTraceEnableLevel(double)
 55 stdcall EtwGetTraceLoggerHandle(ptr)
 57 stdcall -stub EtwNotificationRegistrationW(ptr long ptr long long)
 58 stdcall EtwQueryAllTracesA(ptr long ptr)
 59 stdcall EtwQueryAllTracesW(ptr long ptr)
-60 stdcall -stub EtwQueryTraceA(double str ptr)
-61 stdcall -stub EtwQueryTraceW(double wstr ptr)
-62 stdcall -stub EtwReceiveNotificationsA() # FIXME prototype
-63 stdcall -stub EtwReceiveNotificationsW() # FIXME prototype
+60 stdcall EtwQueryTraceA(double str ptr)
+61 stdcall EtwQueryTraceW(double wstr ptr)
+62 stdcall -stub EtwReceiveNotificationsA(long long long long)
+63 stdcall -stub EtwReceiveNotificationsW(long long long long)
 64 stdcall EtwRegisterTraceGuidsA(ptr ptr ptr long ptr str str ptr)
 65 stdcall EtwRegisterTraceGuidsW(ptr ptr ptr long ptr wstr wstr ptr)
 66 stdcall EtwStartTraceA(ptr str ptr)
 67 stdcall EtwStartTraceW(ptr wstr ptr)
-68 stdcall -stub EtwStopTraceA(double str ptr)
-69 stdcall -stub EtwStopTraceW(double wstr ptr)
+68 stdcall EtwStopTraceA(double str ptr)
+69 stdcall EtwStopTraceW(double wstr ptr)
 70 stdcall EtwTraceEvent(double ptr)
 71 stdcall -stub EtwTraceEventInstance(double ptr ptr ptr)
 72 varargs EtwTraceMessage(ptr long ptr long)
 73 stdcall -stub EtwTraceMessageVa(double long ptr long ptr)
 74 stdcall EtwUnregisterTraceGuids(double)
-75 stdcall -stub EtwUpdateTraceA(double str ptr)
-76 stdcall -stub EtwUpdateTraceW(double wstr ptr)
-# EtwpGetTraceBuffer
-# EtwpSetHWConfigFunction
+75 stdcall EtwUpdateTraceA(double str ptr)
+76 stdcall EtwUpdateTraceW(double wstr ptr)
+77 stdcall -stub EtwpGetTraceBuffer(long long long long)
+78 stdcall -stub EtwpSetHWConfigFunction(ptr long)
 79 stdcall -arch=i386 KiFastSystemCall()
 80 stdcall -arch=i386 KiFastSystemCallRet()
 81 stdcall -arch=i386 KiIntSystemCall()
 501 stdcall RtlConvertSharedToExclusive(ptr)
 502 stdcall RtlConvertSidToUnicodeString(ptr ptr long)
 503 stdcall RtlConvertToAutoInheritSecurityObject(ptr ptr ptr ptr long ptr)
-# stdcall RtlConvertUiListToApiList
+504 stdcall RtlConvertUiListToApiList(ptr ptr long)
 505 stdcall -arch=win32 -ret64 RtlConvertUlongToLargeInteger(long)
 506 stdcall RtlCopyLuid(ptr ptr)
 507 stdcall RtlCopyLuidAndAttributesArray(long ptr ptr)
 539 stdcall RtlDeactivateActivationContext(long long)
 # RtlDebugPrintTimes
 541 stdcall RtlDecodePointer(ptr)
-542 stdcall RtlDecodeSystemPointer(ptr) RtlEncodeSystemPointer
+542 stdcall RtlDecodeSystemPointer(ptr)
 543 stdcall RtlDecompressBuffer(long ptr long ptr long ptr)
 544 stdcall RtlDecompressFragment(long ptr long ptr long long ptr ptr)
 545 stdcall RtlDefaultNpAcl(ptr)
 732 stdcall RtlIpv6StringToAddressExW(wstr ptr ptr ptr)
 733 stdcall RtlIpv6StringToAddressW(wstr ptr ptr)
 734 stdcall RtlIsActivationContextActive(ptr)
-# stdcall RtlIsCriticalSectionLocked
-# stdcall RtlIsCriticalSectionLockedByThread
+735 stdcall RtlIsCriticalSectionLocked(ptr)
+736 stdcall RtlIsCriticalSectionLockedByThread(ptr)
 737 stdcall RtlIsDosDeviceName_U(wstr)
 738 stdcall RtlIsGenericTableEmpty(ptr)
 739 stdcall RtlIsGenericTableEmptyAvl(ptr)
 @ stdcall -arch=x86_64 RtlLookupFunctionEntry(long ptr ptr)
 767 stdcall RtlMakeSelfRelativeSD(ptr ptr ptr)
 768 stdcall RtlMapGenericMask(long ptr)
-# stdcall RtlMapSecurityErrorToNtStatus
+769 stdcall RtlMapSecurityErrorToNtStatus(long)
 770 stdcall RtlMoveMemory(ptr ptr long)
 771 stdcall RtlMultiAppendUnicodeStringBuffer(ptr long ptr)
 772 stdcall RtlMultiByteToUnicodeN(ptr long ptr ptr long)
 779 stdcall RtlNewSecurityObjectEx(ptr ptr ptr ptr long long ptr ptr)
 780 stdcall RtlNewSecurityObjectWithMultipleInheritance(ptr ptr ptr ptr long long long ptr ptr)
 781 stdcall RtlNormalizeProcessParams(ptr)
-782 stdcall RtlNtPathNameToDosPathName(ptr ptr ptr ptr) ; CHECKME
+782 stdcall RtlNtPathNameToDosPathName(long ptr ptr ptr) ; CHECKME (last arg)
 783 stdcall RtlNtStatusToDosError(long)
 784 stdcall RtlNtStatusToDosErrorNoTeb(long)
 785 stdcall RtlNumberGenericTableElements(ptr)
 786 stdcall RtlNumberGenericTableElementsAvl(ptr)
 787 stdcall RtlNumberOfClearBits(ptr)
 788 stdcall RtlNumberOfSetBits(ptr)
-# stdcall RtlOemStringToUnicodeSize(ptr)
+789 stdcall RtlOemStringToUnicodeSize(ptr) RtlxOemStringToUnicodeSize
 790 stdcall RtlOemStringToUnicodeString(ptr ptr long)
 791 stdcall RtlOemToUnicodeN(ptr long ptr ptr long)
 792 stdcall RtlOpenCurrentUser(long ptr)
 903 stdcall RtlTryEnterCriticalSection(ptr)
 # stdcall RtlUnhandledExceptionFilter2
 905 stdcall RtlUnhandledExceptionFilter(ptr)
-# stdcall RtlUnicodeStringToAnsiSize(ptr)
+906 stdcall RtlUnicodeStringToAnsiSize(ptr) RtlxUnicodeStringToAnsiSize
 907 stdcall RtlUnicodeStringToAnsiString(ptr ptr long)
 908 stdcall RtlUnicodeStringToCountedOemString(ptr ptr long)
 909 stdcall RtlUnicodeStringToInteger(ptr long ptr)
-# stdcall RtlUnicodeStringToOemSize(ptr)
+910 stdcall RtlUnicodeStringToOemSize(ptr) RtlxUnicodeStringToOemSize
 911 stdcall RtlUnicodeStringToOemString(ptr ptr long)
 912 stdcall RtlUnicodeToCustomCPN(ptr ptr long ptr wstr long)
 913 stdcall RtlUnicodeToMultiByteN(ptr long ptr ptr long)
 948 stdcall RtlZeroMemory(ptr long)
 949 stdcall RtlZombifyActivationContext(ptr)
 950 stdcall RtlpApplyLengthFunction(long long ptr ptr)
-951 stdcall RtlpEnsureBufferSize(ptr ptr ptr) ; CHECKME
+951 stdcall RtlpEnsureBufferSize(long ptr long)
 # stdcall RtlpNotOwnerCriticalSection
 953 stdcall RtlpNtCreateKey(ptr long ptr long ptr ptr)
 954 stdcall RtlpNtEnumerateSubKey(ptr ptr long long)
 961 stdcall RtlxAnsiStringToUnicodeSize(ptr)
 962 stdcall RtlxOemStringToUnicodeSize(ptr)
 963 stdcall RtlxUnicodeStringToAnsiSize(ptr)
-964 stdcall RtlxUnicodeStringToOemSize(ptr) ; RtlUnicodeStringToOemSize
+964 stdcall RtlxUnicodeStringToOemSize(ptr)
 965 stdcall -ret64 VerSetConditionMask(double long long)
 966 stdcall ZwAcceptConnectPort(ptr long ptr long long ptr) NtAcceptConnectPort
 967 stdcall ZwAccessCheck(ptr long long ptr ptr ptr ptr ptr) NtAccessCheck
 1312 cdecl _wcsicmp(wstr wstr)
 1313 cdecl _wcslwr(wstr)
 1314 cdecl _wcsnicmp(wstr wstr long)
-# _wcstoui64
+1315 cdecl _wcstoui64(wstr ptr long)
 1316 cdecl _wcsupr(wstr)
 1317 cdecl _wtoi(wstr)
 1318 cdecl _wtoi64(wstr)
 1351 cdecl memcpy(ptr ptr long) memmove
 1352 cdecl memmove(ptr ptr long)
 1353 cdecl memset(ptr long long)
-1354 cdecl -arch=i386,x86_64 pow(double double)
+1354 cdecl -arch=i386,x86_64,arm pow(double double)
 1355 cdecl qsort(ptr long long ptr)
 1356 cdecl sin(double)
 1357 varargs sprintf(ptr str)