[CMAKE] Introduce the atl_classes interface library
[reactos.git] / dll / shellext / acppage / CMakeLists.txt
index a8708a5..fe694f8 100644 (file)
@@ -6,11 +6,7 @@ if(NOT MSVC)
     add_compile_flags_language("-std=c++11" "CXX")
 endif()
 
-add_definitions(
-    -D_ATL_NO_EXCEPTIONS)
-
 include_directories(
-    ${REACTOS_SOURCE_DIR}/sdk/lib/atl
     ${REACTOS_SOURCE_DIR}/dll/appcompat/apphelp
     ${REACTOS_SOURCE_DIR})
 spec2def(acppage.dll acppage.spec ADD_IMPORTLIB)
@@ -31,7 +27,7 @@ add_library(acppage MODULE
     ${CMAKE_CURRENT_BINARY_DIR}/acppage.def)
 
 set_module_type(acppage win32dll UNICODE)
-target_link_libraries(acppage wine uuid cpprt)
+target_link_libraries(acppage wine uuid cpprt atl_classes)
 add_delay_importlibs(acppage apphelp ole32 oleaut32 shlwapi comctl32 sfc_os)
 add_importlibs(acppage shell32 user32 advapi32 msvcrt kernel32)
 add_pch(acppage precomp.h SOURCE)