[SDK] Don't just infinitely spam the DbgPrint in the bootloader (#6763)
[reactos.git] / dll / shellext / deskadp / CMakeLists.txt
index 99fa79c..e0e0181 100644 (file)
@@ -6,22 +6,15 @@ list(APPEND SOURCE
     shxiface.c
     precomp.h)
 
-add_library(deskadp SHARED
+add_rc_deps(deskadp.rc ${CMAKE_CURRENT_SOURCE_DIR}/resources/adapter.ico)
+
+add_library(deskadp MODULE
     ${SOURCE}
     deskadp.rc
     ${CMAKE_CURRENT_BINARY_DIR}/deskadp.def)
 
 set_module_type(deskadp win32dll UNICODE)
 target_link_libraries(deskadp uuid)
-
-add_importlibs(deskadp
-    user32
-    gdi32
-    comctl32
-    ole32
-    msvcrt
-    kernel32
-    ntdll)
-
+add_importlibs(deskadp user32 gdi32 comctl32 ole32 msvcrt kernel32 ntdll)
 add_pch(deskadp precomp.h SOURCE)
 add_cd_file(TARGET deskadp DESTINATION reactos/system32 FOR all)