[MMIXER] Fix additional data size initialization for different audio formats (#6753)
[reactos.git] / dll / shellext / fontext / CMakeLists.txt
index 4257de3..b0ddec8 100644 (file)
@@ -1,28 +1,32 @@
 
-set_rc_compiler()
+remove_definitions(-D_WIN32_WINNT=0x502 -DWINVER=0x502)
+add_definitions(-D_WIN32_WINNT=0x601 -DWINVER=0x601)
+
 spec2def(fontext.dll fontext.spec)
 
-add_library(fontext SHARED
-    fontext.c
-    regsvr.c
+list(APPEND SOURCE
+    CDataObject.cpp
+    CEnumFonts.cpp
+    CFontCache.cpp
+    CFontCache.hpp
+    CFontExt.cpp
+    CFontExt.hpp
+    CFontMenu.cpp
+    fontext.cpp
+    fontpidl.cpp
+    fontpidl.hpp
+    precomp.h
+    resource.h)
+
+add_library(fontext MODULE
+    ${SOURCE}
     fontext.rc
+    fontext.spec
     ${CMAKE_CURRENT_BINARY_DIR}/fontext.def)
 
 set_module_type(fontext win32dll UNICODE)
-
-target_link_libraries(fontext uuid)
-
-add_importlibs(fontext
-    user32
-    gdi32
-    ole32
-    shlwapi
-    lz32
-    advapi32
-    setupapi
-    msvcrt
-    kernel32
-    ntdll)
-
-add_pch(fontext fontext.h)
+target_link_libraries(fontext uuid wine cpprt atl_classes)
+add_delay_importlibs(fontext ole32 oleaut32 shlwapi gdi32)
+add_importlibs(fontext shell32 advapi32 user32 msvcrt kernel32 ntdll)
+add_pch(fontext precomp.h SOURCE)
 add_cd_file(TARGET fontext DESTINATION reactos/system32 FOR all)