[CMAKE]
[reactos.git] / dll / shellext / fontext / CMakeLists.txt
index 9dff1da..d758354 100644 (file)
@@ -1,16 +1,17 @@
 
 set_unicode()
-
-spec2def(fontext ${CMAKE_CURRENT_SOURCE_DIR}/fontext.spec ${CMAKE_CURRENT_BINARY_DIR}/fontext.def)
+set_rc_compiler()
+spec2def(fontext.dll fontext.spec)
 
 add_library(fontext SHARED
     fontext.c
     regsvr.c
-    fontext.rc)
+    fontext.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/fontext.def)
 
 set_module_type(fontext win32dll)
 
-target_link_libraries(fontext ${CMAKE_CURRENT_BINARY_DIR}/fontext.def uuid)
+target_link_libraries(fontext uuid)
 
 add_importlibs(fontext
     user32
@@ -20,8 +21,8 @@ add_importlibs(fontext
     lz32
     advapi32
     setupapi
+    msvcrt
     kernel32
     ntdll)
 
-add_dependencies(fontext fontext_def)
 add_cab_target(fontext 1)