[SHELL32] Remove 2 redundant initializations
[reactos.git] / dll / shellext / ntobjshex / CMakeLists.txt
index f8a6e73..f5ce057 100644 (file)
@@ -1,17 +1,6 @@
 
 project(SHELL)
 
-set_cpp(WITH_RUNTIME)
-
-if(NOT MSVC)
-    # HACK: this should be enabled globally!
-    add_compile_flags_language("-std=c++11" "CXX")
-endif()
-
-include_directories(
-    ${REACTOS_SOURCE_DIR}/sdk/lib/atl
-    ${REACTOS_SOURCE_DIR})
-
 spec2def(ntobjshex.dll ntobjshex.spec)
 
 file(GLOB_RECURSE ntobjshex_rc_deps resources/*.*)
@@ -30,7 +19,7 @@ add_library(ntobjshex MODULE
     ${CMAKE_CURRENT_BINARY_DIR}/ntobjshex.def)
 
 set_module_type(ntobjshex win32dll UNICODE)
-target_link_libraries(ntobjshex uuid wine atlnew)
+target_link_libraries(ntobjshex uuid wine cpprt atl_classes)
 
 add_importlibs(ntobjshex
     advapi32