[CMAKE]
[reactos.git] / dll / shellext / slayer / CMakeLists.txt
index ccd3717..5830f46 100644 (file)
@@ -1,15 +1,19 @@
 
 set_unicode()
+set_rc_compiler()
 
-spec2def(slayer ${CMAKE_CURRENT_SOURCE_DIR}/slayer.spec ${CMAKE_CURRENT_BINARY_DIR}/slayer.def)
+spec2def(slayer.dll slayer.spec)
 
-list(APPEND SOURCE slayer.c slayer.rc)
+list(APPEND SOURCE
+    slayer.c
+    slayer.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/slayer.def)
 
 add_library(slayer SHARED ${CMAKE_CURRENT_BINARY_DIR}/slayer_precomp.h.gch ${SOURCE})
 
 set_module_type(slayer win32dll)
 
-target_link_libraries(slayer ${CMAKE_CURRENT_BINARY_DIR}/slayer.def uuid)
+target_link_libraries(slayer uuid)
 
 add_importlibs(slayer
     user32
@@ -17,9 +21,10 @@ add_importlibs(slayer
     advapi32
     ole32
     shell32
+    msvcrt
     kernel32
     ntdll)
 
 add_pch(slayer ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_dependencies(slayer slayer_def)
-add_cab_target(slayer 1)
+
+add_cd_file(TARGET slayer DESTINATION reactos/system32 FOR all)