[CMAKE]
[reactos.git] / dll / shellext / slayer / CMakeLists.txt
index feeda20..b0fb986 100644 (file)
@@ -1,15 +1,18 @@
 
 set_unicode()
 
-spec2def(slayer ${CMAKE_CURRENT_SOURCE_DIR}/slayer.spec ${CMAKE_CURRENT_BINARY_DIR}/slayer.def)
+spec2def(slayer.dll slayer.spec)
 
-list(APPEND SOURCE slayer.c slayer.rc)
+list(APPEND SOURCE
+    slayer.c
+    slayer.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/slayer.def)
 
 add_library(slayer SHARED ${CMAKE_CURRENT_BINARY_DIR}/slayer_precomp.h.gch ${SOURCE})
 
 set_module_type(slayer win32dll)
 
-target_link_libraries(slayer ${CMAKE_CURRENT_BINARY_DIR}/slayer.def uuid)
+target_link_libraries(slayer uuid)
 
 add_importlibs(slayer
     user32
@@ -21,5 +24,5 @@ add_importlibs(slayer
     ntdll)
 
 add_pch(slayer ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_dependencies(slayer slayer_def)
-add_livecd_target(slayer reactos/system32)
+
+add_cab_target(slayer 1)