[NTDLL] Allow shimdata to override the process manifest.
[reactos.git] / dll / shellext / stobject / CMakeLists.txt
index d718d3b..e25e433 100644 (file)
@@ -9,25 +9,40 @@ if(NOT MSVC)
 endif()
 
 include_directories(
-    ${REACTOS_SOURCE_DIR}/lib/atl
+    ${REACTOS_SOURCE_DIR}/sdk/lib/atl
     ${REACTOS_SOURCE_DIR})
 
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
+
 spec2def(stobject.dll stobject.spec)
 
-add_library(stobject SHARED
+file(GLOB_RECURSE stobject_rc_deps resources/*.*)
+add_rc_deps(stobject.rc ${stobject_rc_deps})
+
+list(APPEND SOURCE
     csystray.cpp
     stobject.cpp
-    stobject.rc
+    hotplug.cpp
+    power.cpp
     volume.cpp
+    precomp.h)
+
+add_library(stobject SHARED
+    ${SOURCE}
+    stobject.rc
     ${CMAKE_CURRENT_BINARY_DIR}/stobject.def)
 
 set_module_type(stobject win32dll UNICODE)
 target_link_libraries(stobject uuid wine atlnew)
 
 add_importlibs(stobject
+    setupapi
     advapi32
     winmm
     ole32
+    oleaut32
+    powrprof
     shlwapi
     shell32
     comctl32
@@ -37,4 +52,5 @@ add_importlibs(stobject
     kernel32
     ntdll)
 
+add_pch(stobject precomp.h SOURCE)
 add_cd_file(TARGET stobject DESTINATION reactos/system32 FOR all)