[CMAKE]
[reactos.git] / dll / win32 / acledit / CMakeLists.txt
index 26d75b3..5a92340 100644 (file)
@@ -1,19 +1,17 @@
 
 set_unicode()
+set_rc_compiler()
+spec2def(acledit.dll acledit.spec)
 
 list(APPEND SOURCE
     acledit.c
     stubs.c
-    acledit.rc)
-
-spec2def(acledit ${CMAKE_CURRENT_SOURCE_DIR}/acledit.spec ${CMAKE_CURRENT_BINARY_DIR}/acledit.def)
+    acledit.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/acledit.def)
 
 add_library(acledit SHARED ${SOURCE})
 
 set_module_type(acledit win32dll)
-
-target_link_libraries(acledit ${CMAKE_CURRENT_BINARY_DIR}/acledit.def)
-add_importlibs(acledit ntdll)
-
-add_dependencies(acledit acledit_def)
-add_livecd_target(acledit reactos/system32)
+add_importlibs(acledit msvcrt kernel32 ntdll)
+add_cd_file(TARGET acledit DESTINATION reactos/system32 FOR all)
+add_importlib_target(acledit.spec)