[CMAKE]
[reactos.git] / dll / win32 / acledit / CMakeLists.txt
index 65983d7..e99e698 100644 (file)
@@ -1,20 +1,20 @@
 
+set_unicode()
 
+list(APPEND SOURCE
+    acledit.c
+    stubs.c
+    acledit.rc
+    )
 
-add_definitions(-DUNICODE -D_UNICODE)
+add_library(acledit SHARED ${SOURCE})
 
-file(GLOB_RECURSE SOURCE *.c)
+set_module_type(acledit win32dll)
 
-spec2def(acledit ${CMAKE_CURRENT_SOURCE_DIR}/acledit.spec ${CMAKE_CURRENT_BINARY_DIR}/acledit.def)
+set_pdef_file(acledit acledit.pdef)
 
-add_library(acledit SHARED
-    ${SOURCE}
-    ${CMAKE_CURRENT_SOURCE_DIR}/acledit.rc)
+add_importlibs(acledit ntdll)
 
-set_target_properties(acledit PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+add_cab_target(acledit 1)
 
-target_link_libraries(acledit
-    ${CMAKE_CURRENT_BINARY_DIR}/acledit.def
-    -lntdll)
-
-add_dependencies(acledit acledit_def psdk buildno_header)
+add_importlib_target(${CMAKE_CURRENT_BINARY_DIR}/acledit.def)