[LT2013]
[reactos.git] / dll / win32 / activeds / CMakeLists.txt
index 183251c..a4c7b42 100644 (file)
@@ -1,19 +1,21 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES> -L${REACTOS_BINARY_DIR}/lib/3rdparty/mingw")
-
 add_definitions(-D__WINESRC__)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(activeds ${CMAKE_CURRENT_SOURCE_DIR}/activeds.spec ${CMAKE_CURRENT_BINARY_DIR}/activeds.def)
+spec2def(activeds.dll activeds.spec)
+
+list(APPEND SOURCE
+    activeds_main.c
+    stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/activeds.def)
+
+add_library(activeds SHARED ${SOURCE})
 
-add_library(activeds SHARED activeds_main.c)
+set_module_type(activeds win32dll)
 
-set_target_properties(activeds PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+target_link_libraries(activeds wine)
 
-target_link_libraries(activeds 
-     ${CMAKE_CURRENT_BINARY_DIR}/activeds.def
-     wine
-     mingw_common)
+add_importlibs(activeds msvcrt kernel32 ntdll)
 
-add_dependencies(activeds activeds_def psdk)
+add_cd_file(TARGET activeds DESTINATION reactos/system32 FOR all)