Sync with trunk r63174.
[reactos.git] / dll / win32 / atl / CMakeLists.txt
index 3fc13e9..1d7d6bb 100644 (file)
@@ -1,43 +1,28 @@
 
-add_definitions(-D__WINESRC__)
+add_definitions(
+    -D__WINESRC__
+    -D_ATL_VER=_ATL_VER_30)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_idl_headers(atl_atliface_header atliface.idl)
-generate_idl_iids(atliface.idl)
-
-set_rc_compiler()
-spec2def(atl.dll atl.spec)
+spec2def(atl.dll atl.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
+    atl.c
+    atl30.c
     atl_ax.c
-    atl_main.c
     registrar.c
-    stubs.c
-    rsrc.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/atliface_i.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/atl_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/atl.def)
 
-add_library(atl SHARED ${SOURCE})
-
+add_library(atl SHARED ${SOURCE} rsrc.rc)
 set_module_type(atl win32dll)
-
 target_link_libraries(atl uuid wine)
-
-add_importlibs(atl
-    msvcrt
-    ole32
-    oleaut32
-    user32
-    advapi32
-    gdi32
-    kernel32
-    ntdll)
-
-add_importlib_target(atl.spec)
-
+add_importlibs(atl oleaut32 ole32 user32 gdi32 advapi32 msvcrt kernel32 ntdll)
 add_dependencies(atl atl_atliface_header)
+add_pch(atl precomp.h SOURCE)
 add_cd_file(TARGET atl DESTINATION reactos/system32 FOR all)