Sync with trunk r63174.
[reactos.git] / dll / win32 / atl / CMakeLists.txt
index f930934..1d7d6bb 100644 (file)
@@ -1,5 +1,7 @@
 
-add_definitions(-D__WINESRC__)
+add_definitions(
+    -D__WINESRC__
+    -D_ATL_VER=_ATL_VER_30)
 
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
@@ -9,14 +11,18 @@ include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(atl.dll atl.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
-    atl_main.c
+    atl.c
+    atl30.c
+    atl_ax.c
     registrar.c
+    precomp.h
     ${CMAKE_CURRENT_BINARY_DIR}/atl_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/atl.def)
 
 add_library(atl SHARED ${SOURCE} rsrc.rc)
 set_module_type(atl win32dll)
 target_link_libraries(atl uuid wine)
-add_importlibs(atl atl100 oleaut32 ole32 user32 msvcrt kernel32 ntdll)
+add_importlibs(atl oleaut32 ole32 user32 gdi32 advapi32 msvcrt kernel32 ntdll)
 add_dependencies(atl atl_atliface_header)
+add_pch(atl precomp.h SOURCE)
 add_cd_file(TARGET atl DESTINATION reactos/system32 FOR all)