[CMAKE]
[reactos.git] / dll / win32 / authz / CMakeLists.txt
index d1530a8..18ecd0d 100644 (file)
@@ -5,9 +5,10 @@ list(APPEND SOURCE
     authz.c
     clictx.c
     resman.c
-    authz.rc)
+    authz.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
 
-spec2def(authz ${CMAKE_CURRENT_SOURCE_DIR}/authz.spec ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
+spec2def(authz.dll authz.spec)
 
 add_library(authz SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/authz_precomp.h.gch
@@ -15,9 +16,9 @@ add_library(authz SHARED
 
 set_module_type(authz win32dll)
 
-target_link_libraries(authz ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
+
 
 add_pch(authz ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
 add_importlibs(authz advapi32 kernel32 ntdll)
-add_dependencies(authz authz_def)
+
 add_cab_target(authz 1)