[CMAKE]
[reactos.git] / dll / win32 / authz / CMakeLists.txt
index 18ecd0d..bb652ab 100644 (file)
@@ -1,24 +1,23 @@
 
 set_unicode()
 
+spec2def(authz.dll authz.spec)
+
 list(APPEND SOURCE
     authz.c
     clictx.c
     resman.c
     authz.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/authz_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
 
-spec2def(authz.dll authz.spec)
-
 add_library(authz SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/authz_precomp.h.gch
     ${SOURCE})
 
 set_module_type(authz win32dll)
 
-
-
 add_pch(authz ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_importlibs(authz advapi32 kernel32 ntdll)
+add_importlibs(authz advapi32 msvcrt kernel32 ntdll)
 
-add_cab_target(authz 1)
+add_cd_file(TARGET authz DESTINATION reactos/system32 FOR all)