[CMAKE]
[reactos.git] / dll / win32 / authz / CMakeLists.txt
index 0505643..c9582fc 100644 (file)
@@ -1,13 +1,15 @@
 
 set_unicode()
 
+spec2def(authz.dll authz.spec)
+
 list(APPEND SOURCE
     authz.c
     clictx.c
     resman.c
-    authz.rc)
-
-spec2def(authz ${CMAKE_CURRENT_SOURCE_DIR}/authz.spec ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
+    authz.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/authz_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
 
 add_library(authz SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/authz_precomp.h.gch
@@ -15,9 +17,7 @@ add_library(authz SHARED
 
 set_module_type(authz win32dll)
 
-target_link_libraries(authz ${CMAKE_CURRENT_BINARY_DIR}/authz.def)
-
 add_pch(authz ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
-add_importlibs(authz advapi32 kernel32 ntdll)
-add_dependencies(authz authz_def)
-add_livecd_target(authz reactos/system32)
+add_importlibs(authz advapi32 msvcrt kernel32 ntdll)
+
+add_cd_file(TARGET authz DESTINATION reactos/system32)