Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / dll / win32 / bcrypt / CMakeLists.txt
diff --git a/dll/win32/bcrypt/CMakeLists.txt b/dll/win32/bcrypt/CMakeLists.txt
new file mode 100644 (file)
index 0000000..bcac2af
--- /dev/null
@@ -0,0 +1,18 @@
+
+add_definitions(-D__WINESRC__)
+include_directories(
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/wine
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/mbedtls)
+spec2def(bcrypt.dll bcrypt.spec ADD_IMPORTLIB)
+
+list(APPEND SOURCE
+    bcrypt_main.c
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/bcrypt_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/bcrypt.def)
+
+add_library(bcrypt SHARED ${SOURCE})
+set_module_type(bcrypt win32dll)
+target_link_libraries(bcrypt wine)
+add_importlibs(bcrypt mbedtls advapi32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET bcrypt DESTINATION reactos/system32 FOR all)